Thema Datum  Von Nutzer Rating
Antwort
Rot Mittelabflussplan erstellen durch Formel
28.09.2023 15:22:02 ExcelNoob
NotSolved
28.09.2023 16:39:47 Gast94028
NotSolved
29.09.2023 15:15:01 Gast29264
NotSolved

Ansicht des Beitrags:
Von:
ExcelNoob
Datum:
28.09.2023 15:22:02
Views:
283
Rating: Antwort:
  Ja
Thema:
Mittelabflussplan erstellen durch Formel

Guten Tag zusammen,

ich versuche derzeit einen Mittelabflussplan zu erstellen. Leider bekomme ich es nicht, dass die Formel tut was es soll. Vielleicht hat jemand eine Idee. Gerne auch als VBA Lösung, aber kein muss.

Aufbau:

        2022
  01.01.2022     Quartal 1 Quartal 2 Quartal 3 Quartal 4
  Beginn Fertigstellung Tage 1 2 3 4 5 6 7 8 9 10 11 12
Projektvorbereitung 01.01.2022 22.03.2023 445                        
Beschluss 01.01.2023 01.01.2023   2 2 2 2 2 2 2 2 2 2 2 2
Voruntersuchung und Analyse 02.02.2023 02.03.2024 394                        
Bebauungsplan                              
Abschluss Leistungsphase 0                              

 

Als Formel habe ich nun folgendes unter 2023 - 1 hinterlegt.

=WENN(UND($B6<>"";$C6<>"";$B6=$C6);0;WENN(UND(B6>=MONATSENDE(DATUM(E$3;E$5;-1);0);C6>=MONATSENDE(DATUM(E$3;E$5;-1);0);MONATSENDE(DATUM(E$3;E$5;1);0)>=B6;MONATSENDE(DATUM(E$3;E$5;1);0)>=C6);1;""))

1. Wenn-Funktion: Er soll quasi eine 0 ausgeben wenn Beginn und Fertigstellung gleich sind im entsprechenden Monat. 

2. Wenn-Funktion: Wenn der Monat sich im Bereich Beginn und Fertigstellung befindet soll eine 1 ausgeworfen werden.

Ansonsten soll das Feld leer sein. Mit bedingter Formatierung werden die Felder markiert oder nicht. Am Ende soll es ein normales Gantt-Diagramm sein.

Hat jemand eine Idee, worin der Fehler liegt?

LG und danke vorab.


Ihre Antwort
  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen
Thema: Name: Email:

 
 

  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen

Thema Datum  Von Nutzer Rating
Antwort
Rot Mittelabflussplan erstellen durch Formel
28.09.2023 15:22:02 ExcelNoob
NotSolved
28.09.2023 16:39:47 Gast94028
NotSolved
29.09.2023 15:15:01 Gast29264
NotSolved